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Introduction
ReportAdapter for PDS® 3D is designed to export a PDS database into a Microsoft
Access file, containing one table per discipline. The resulting records are compressed and
internally resolved by code lists.

1.1

General conventions
This document contains many visual cues to help you understand the meaning of certain
words or phrases. The use of different fonts for different types of information allows you
to scan the document for key concepts or commands. Symbols help abbreviate and identify commonly used words, phrases, or groups of related information

Typefaces
Italic

Indicates a system response, which is an explanation of what
the software is doing. For example,
The text is placed in the viewing plane.

Bold

Indicates a command name, parameter name, or dialog box title.
Command paths are shown using an arrow between command
names. For example,
Choose File → Open to load a new file.

Sans serif

Indicates a system prompt or message, which requires an action
be taken by the user. For example,
Select first segment of alignment

Normal typewriter

Indicates an actual file or directory name. For example,
The ASCII report is stored in the layout.rpt file.

Bold typewriter

Indicates what you literally type in. For example,
Key in original.dat to load the ASCII file.

Symbols
This document uses the following symbols to identify special information:
Note – important supplemental information.
Map or path – shows you how to get to a specific command or form.
More information – indicates there is additional or related information.
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Installation

2.1

Setup
Requirements:
▪

Supported operating systems:
▪ Microsoft Windows XP
▪ Microsoft Windows Server 2003
▪ Microsoft Windows Vista
▪ Microsoft Windows 7
PDS 6.4 or later

▪

Administrator rights are required on each computer
ReportAdapter for PDS® 3D. “Run as” is not supported.

to

install

CAXperts

Uninstall
To uninstall the software, select Control panel from the start menu. Then on
•
•
•

Windows 7: in large or small icon view, click Programs and features. If you're
using category view, under Programs, click Uninstall a program.
Windows Vista: in classic view, double-click Programs and features. In control
panel home view, under Programs, click Uninstall a program.
Windows XP/2000: (Double) click the Add or remove programs icon.

Select the program you want to remove, and click Uninstall/Remove. Alternatively, rightclick the program and select Uninstall.

Setup command line (for administrators)
The following command line options are supported by the installer:

/S:<<optional ini file>>
Allow an install to be run in silent mode. As a result, no screens or dialogs will be shown.
This command line option also has an optional INI file that can be passed containing
session variable values. For example:
"C:\output\setup.exe" "/S:C:\setupvars.ini"

This will cause the session variables in the INI file to be used for the setup. The INI file
should be in the format:
[SetupValues]
%AppFolder%=C:\Program Files\MyProduct
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/U:<<XML config file>>
This command line option must be used when calling the uninstall program from the
command line. This command also has an optional XML file that can be passed containing session variable values. For example:
"C:\Program
Files\MyProduct\uninstall.exe"
uct\irunin.xml"

2.2

"/U:C:\Program

Files\MyProd-

Licence
CAXperts software supports two types of licences:

Site licence (local)
Domain based licences are restricted to machines within a 5 miles (8 kilometres) radius
at a specific geographic location (building) for which the licence key file was issued for.
There is no limitation regarding the number of users or machines.
CAXperts will need your Current domain name to issue a licence file (.lic).
The licence file has to be stored on a local or network location accessible by the machine
running the CAXperts product; a licence server is not required.
The location of the licence file should be defined on every machine with the CAXperts
product installed, which can be done
•

Either by setting the environment variable
CAXPERTS_LICENSE_FILE=C:\Program Files (x86)\CAXperts\Licensing\

•

Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License
Manager\CAXPERTS_LICENSE_FILE=C:\Program Files
(x86)\CAXperts\Licensing\

Multiple licence key file locations should be separated by semicolons (“;”).
Note: If the licence key file location is not defined, “C:\Program Files (x86)\CAXperts\Licensing\” is used
Note: The licence key file may be renamed (including the extension). The CAXperts product will check the content of all files in the licence folder(s) for valid keys.
Note: Changes to the key path (in the environment variable or registry key) are read
during the next start of the CAXperts product.

Floating (server) licence
Floating licences require a FlexNET server (lmadmin or lmgrd) accessible by the machine
running the CAXperts product. The licence key file is typically located on the FlexNET
server machine. The licence key file defines the maximum number of seats which can be
used at the same time.
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Note: Every running instance of the CAXperts software product will require one
seat, no matter if the application is running multiple times on the same or different machine(s).
New instances can only be started as long as seats are available and the FlexNET server
is accessible.
The location of the licence server must be defined on every machine with the CAXperts
product installed, which can be done
•

Either by setting the environment variable
CAXPERTS_LICENSE_FILE=@YourServerName

•

Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License Manager\CAXPERTS_LICENSE_FILE=@YourServerName

Every computer name must be preceded by the @ symbol. Multiple licence server locations should be separated by semicolons (“;”).
is the Windows computer name of the machine running lmadmin
(FlexNET server). If lmadmin is running on a non-default port, the port number should
be defined like this: port@ YourServerName.

YourServerName

Note: Changes to the server path (in the environment variable or registry key) are
read during the next start of the CAXperts product.
1.1.1.1.1

Borrowed licences
Licence seats can be borrowed for a period of time from the server and saved to the local
machine. Once the seat has been borrowed the CAXperts application can be used without
any connection to the FlexNET server.

To borrow a licence seat press the Borrow seat button, define the loan period (up to 7
days) and press OK. When the borrowed seat expires it gets automatically returned back
to the FlexNET server.
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The seat can be returned earlier by pressing the Return borrowed seat button.

Note: Without a valid licence file the software will run in demo mode.
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ReportAdapter for PDS® 3D
The ReportAdapter for PDS® 3D is used to extract MTO-data of standard PDS disciplines (Piping, Equipment and Structural) out of an existing project.
Note: ReportAdapter for PDS® 3D requires PDS and a PDS (3D) licence seat on a
SmartPlant Licence Server.

3.1

Prerequisites
ReportAdapter for PDS® 3D uses Intergraph Material Data Publisher to publish material
data associated with a PDS model. This process requires MTO-Schema, which needs to
be created using RIS and initialized by opening project in Material Data Publisher.

Note: See the Intergraph PDS manual for details

3.2

Extracting MTO-Data
Start ReportAdapter for PDS® 3D and select your PDS project from the Combo Box:
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Select disciplines and models to extract:

Browse with the (
) button to select a location to create a Microsoft Access Database
file in which the results will be shown.
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All the settings are stored automatically in the configuration file which is found under
Tools>Settings.
• Run Material Data Publisher – starts MDP job to update the data in the MTO schema
Start the process by clicking the Extract button.

3.3

Settings
All program settings (selected disciplines and models …) are stored automatically for
each project in the configuration file located by default in the user profile folder. The
location of the configuration file can be changed by using menu Tools->Settings.
Note: You can import/export the configuration file by using menu File->Load settings from file/Save settings to file.

General options
•

Copy iso files - if enabled, iso files (*.i01, ...) will be copied into the folder of
the output Access database.

•

Save all PDS tables - if enabled, save all PD and MTO tables into output database

Material Data Publisher options:
•
•
•
•

Forced Publishing – re-publish up-to-date models
Standard Note Library – publish standard note library
Long Material – resolve long material description
Short Material – resolve short material description
11
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Load settings from file
To import the settings into the file configuration file use menu “File->Load settings from
file”.
Note: The location of the project configuration file is not affected, only the content
of the file will be overwritten

Save settings to file
To export the settings from the file configuration file use menu “File->Save settings to
file”.
Note: The location of the file configuration file is not affected

3.4

Advanced settings
SQL statements to extend standard output tables with user defined attributes or perform
some other tasks (like creating additional tables, queries) can be defined in the configuration file. They will be executed automatically after the extraction process has been completed.
[SQL]
SQL1=ALTER TABLE Piping ADD COLUMN [MyAttribute] VARCHAR(255);
SQL2=UPDATE [Piping] SET [MyAttribute] = 'Test';

If the "Save all PDS tables" option is enabled, any valid attributes from PD and MTO
schemas can be used inside these SQL statements.

3.5

Content of result database
When extraction process has finished, ReportAdapter for PDS® 3D prompts for opening the resulting database in Microsoft Access.
There are some sample reports for Piping and Equipment with typical task-specific attributes predefined. These reports can also be used as templates to create other reports.
The philosophy of ReportAdapter for PDS® 3D is to have one table with all attributes
per discipline.
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Piping
The table contains the following objects:
•
•
•
•
•
•
•

Pipe
Pipe Component
Instrument
Pipe Specialty Item
Support
Bolt
Gasket

Equipment
The Equipment table contains one row for each nozzle and one additional row for each
Equipment without any nozzles as shown below:
The table contains the following objects:
•
•

Equipment
All Type of Nozzles

Structural
The table contains the following objects:
•

Linear Member

Project
The table includes the information about the plant and database.
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3.6

Command Line Mode
The ReportAdapter for PDS® 3D can be used from the command line to automate the
exportation of a PDS data.
To then open the ReportAdapter batch mode help type in the installation path of ReportAdapter followed by “\PDS ReportAdapter.exe” /?.
C:\>”C:\Program Files\CAXperts\PDS ReportAdapter\PDS ReportAdapter.exe” /?

"PDS ReportAdapter.exe" [/cmd control_file.cmd] [/project project_name] [/config config_file.ini] [/output output_file.mdb]

/cmd control_file.cmd

Path to the control file

/project project_name

PDS project name to process

/config config_file.ini Config file which contains the settings for the extraction. If a configuration file is not defined, the last
configuration will be used
/output output_file.mdb Output database. If Output database is not defined,
the last configuration will be used

14

Technical support

4

Technical support
Need more help? Contact CAXperts support by email, online, or phone:
mailto:support@caxperts.com
http://www.caxperts.com/component/option,com_contact
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