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Introduction
ReviewAdapter captures 3D graphics and attributes from Intergraph SmartPlant Review and
stores it in a file (*.upvc). This file is used as input for CAXperts UniversalPlantViewer
Builder to generate Universal Plant Viewer or 3D PDF session.

1.1

General conventions
This document contains many visual cues to help you understand the meaning of certain words
or phrases. The use of different fonts for different types of information allows you to scan the
document for key concepts or commands. Symbols help abbreviate and identify commonly used
words, phrases, or groups of related information

Typefaces
Italic

Indicates a system response, which is an explanation
of what the software is doing. For example,
The text is placed in the viewing plane.

Bold

Indicates a command name, parameter name, or dialog
box title. Command paths are shown using an arrow
between command names. For example,
Choose File → Open to load a new file.

Normal
typewriter

Indicates an actual file or directory name. For example,
The ASCII report is stored in the layout.rpt file.

Bold typewriter

Indicates what you literally type in. For example,
Key in original.dat to load the ASCII file.

Symbols
This document uses the following symbols to identify special information:
Note – important supplemental information.
Map or path – shows you how to get to a specific command or form.
More information – indicates there is additional or related information.
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Installation
Requirements:
▪

Hardware (minimum):
▪
▪

▪

Hardware (recommended):
▪
▪
▪
▪

▪

CPU: quad-core, >=3.4 GHz
RAM: >=8GB
OS, %TEMP%, input and output folders on SSD
Full HD resolution

Supported operating systems:
▪
▪

▪
▪
▪

CPU: double-core, 2.5 GHz
RAM: 3 GB

Microsoft Windows 7-10
Microsoft Windows 2008-2012R2

Intergraph SmartPlant Review 2014 R1 or later (32 or 64 bit)
Intergraph SmartSketch 2014 or later (32 bit)
Microsoft .NET Framework 4.0

Administrator rights are required on each computer to install CAXperts ReviewAdapter. “Run
as” is not supported.

Uninstall
To uninstall the software, select Control panel from the start menu. Then on large or small icon
view, click Programs and features. If you are using category view, under Programs, click Uninstall a program.
Select the program you want to remove, and click Uninstall/Remove. Alternatively, right-click
the program and select Uninstall.

Setup command line (for administrators)
The following command line options are supported by the installer:
/S:<<optional ini file>>
Allow an install to be run in silent mode. As a result, no screens or dialogs will be shown.
This command line option also has an optional INI file that can be passed containing session
variable values. For example:
"C:\output\setup.exe" "/S:C:\setupvars.ini"

This will cause the session variables in the INI file to be used for the setup. The INI file should
be in the format:
[SetupValues]
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%AppFolder%=C:\Program Files\MyProduct

/U:<<XML config file>>
This command line option must be used when calling the uninstall program from the command
line. This command also has an optional XML file that can be passed containing session variable
values. For example:
"C:\Program Files\MyProduct\uninstall.exe" "/U:C:\Program Files\MyProduct\iru
nin.xml"

2.1

Licence
CAXperts software supports two types of licences:

Site licence (local)
Domain based licences are restricted to machines within a 5 miles (8 kilometres) radius at a specific geographic location (building) for which the licence key file was issued for. There is no
limitation regarding the number of users or machines.
CAXperts will need your Current domain name to issue a licence file (.lic).
The licence file has to be stored on a local or network location accessible by the machine running
the CAXperts product; a licence server is not required.
The location of the licence file should be defined on every machine with the CAXperts product
installed, which can be done


Either by setting the environment variable
CAXPERTS_LICENSE_FILE=C:\Program Files (x86)\CAXperts\Licensing\



Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License
Manager\CAXPERTS_LICENSE_FILE=C:\Program Files
(x86)\CAXperts\Licensing\

Multiple licence key file locations should be separated by semicolons (“;”).
Note: If the licence key file location is not defined, “C:\Program Files (x86)\CAXperts\Licensing\” is used
Note: The licence key file may be renamed (including the extension). The CAXperts product will check the content of all files in the licence folder(s) for valid keys.
Note: Changes to the key path (in the environment variable or registry key) are read during
the next start of the CAXperts product.

Floating (server) licence
Floating licences require a FlexNET server (lmadmin or lmgrd) accessible by the machine running
the CAXperts product. The licence key file is typically located on the FlexNET server machine.
The licence key file defines the maximum number of seats which can be used at the same time.
Note: Every running instance of the CAXperts software product will require one seat, no
matter if the application is running multiple times on the same or different machine(s).
New instances can only be started as long as seats are available and the FlexNET server is accessible.
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The location of the licence server must be defined on every machine with the CAXperts product
installed, which can be done


Either by setting the environment variable
CAXPERTS_LICENSE_FILE=@YourServerName



Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License
Manager\CAXPERTS_LICENSE_FILE=@YourServerName

Every computer name must be preceded by the @ symbol. Multiple licence server locations should
be separated by semicolons (“;”).
YourServerName is the Windows computer name of the machine running lmadmin (FlexNET

server). If lmadmin is running on a non-default port, the port number should be defined like this:
port@ YourServerName.
Note: Changes to the server path (in the environment variable or registry key) are read during the next start of the CAXperts product.
Borrowed licences
Licence seats can be borrowed for a period of time from the server and saved to the local machine.
Once the seat has been borrowed the CAXperts application can be used without any connection
to the FlexNET server.

To borrow a licence seat press the Borrow seat button, define the loan period (up to 7 days) and
press OK. When the borrowed seat expires it gets automatically returned back to the FlexNET
server.

The seat can be returned earlier by pressing the Return borrowed seat button.
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Note: Without a valid licence file the software will run in demo mode.
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Using ReviewAdapter
ReviewAdapter Setup detects automatically the platform of Intergraph SmartPlant Review (32 or
64 bit) and copies to disc appropriate version of ReviewAdapter. (64 bit version of ReviewAdapter
is required to work with 64 bit version of SmartPlant Review).
Start ReviewAdapter and select an input file. These Intergraph SmartPlant Review files are supported: *.vue, *.svf and *.dri.

Output file: defines the path to the *.upvc output file. The file contains all required information
(like graphics or attributes) in order to generate UniversalPlantViewer or 3D PDF output using
CAXperts UniversalPlantViewer Builder software.
If the *.upvc output file already exists, ReviewAdapter will work in update mode and re-capture
changes only.

3.1

Settings
All settings are stored automatically in the configuration file of the user profile. The location of
the configuration file can be changed in the Tools → Settings menu.
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General
Configuration File:
To export the settings use File → Save settings to file:

To import the settings from file use File → Load settings from file.
Note: “Load settings from file” doesn’t change the current location of the configuration
file. Once the settings have been imported any further changes are stored in the current configuration file displayed in the Tools → Settings menu.
Aspects:
All aspects from the SmartPlantReview session are captured automatically.
No additional settings are required
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Advanced

Consider existing Display Sets - if enabled existing the visibility and colours are retaken from
existing SmartPlant Review Display Set.
Maximum objects per capture group - This is the maximal number of objects captured at one
time. Higher value increase performance but may also cause an over of SmartPlant Review
MDB file (which is limited to max 2 Gb). SmartPlant Review needs longer to start with the high
number of display sets.
Stroking tolerance - Defines the quality of exported graphic. Higher values means better
graphical quality, but also significantly increases the size of outputted graphic (slower performance in Universal Plant Viewer).
Advanced Graphic Handling if this option is activated, advanced measurement option will be
available in Universal Plant Viewer (like snapping to edges). Takes addition time while capturing.
Use PDS Levels as Aspects: (applicable for DRI session only). If enabled, every Microstation
Level is treated as a separate aspect. Takes addition time while capturing.
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3.2

Command line mode
Note: Due to some restrictions in SmartPlant Review, absolute paths must be used in ReviewAdapter command line commands.
ReviewAdapter can also be used in command line mode. Use the following command to show
the command line arguments:
C:\>”C:\Program Files\CAXperts\ReviewAdapter\ReviewAdapter.exe” /?

Command line arguments:

ReviewAdapter requires access to the desktop (to run SmartPlant Review), therefore to be
able to run the software as a scheduled task following steps are required:
1. Download https://download.sysinternals.com/files/PSTools.zip and save to disk (e.q. into
D:\PSTools\ folder).
2. Create BAT file (e.q. D:\ReviewAdapter_Batch.bat) which is used to run ReviewAdapter
from command line. Adjust ReviewAdapter path and parameters:
D:\PSTools\psexec.exe -s -i 0 /accepteula “C:\Program Files\CAXperts\ReviewAdapter\ReviewAdapter.exe" -input:C:\Example.vue -output:C:\Output\Example.upvc

-
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Notes:
psexec.exe executes ReviewAdapter in a separate console – session 0. Software UI won’t be
accessible or visible on the active desktop. In order to switch to session 0 press “View the
message” button on the Interactive Service Detection window, which will appear automatically after D:\ReviewAdapter_Batch.bat has been started.

Using ReviewAdapter

If this window won’t be shown, make sure “Interactive Services” services is enabled in a
control panel of windows.
To revert back from session 0 console to the main desktop press button:

-

D:\ReviewAdapter_Batch.bat is running in a separate session, the active user can continue
working with windows or logoff. The session 0 will be executed in the background.
D:\ReviewAdapter_Batch.bat script is executed under LocalSystem account with limited
permissions without network access. Input and output files must be located on the local
drive. If you need to access the network (e.q. copy result upvc file to a network drive) add
corresponding at the end of D:\ReviewAdapter_Batch.bat.
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Advanced features

4.1

Advanced configuration for capturing graphics
This chapter is for advanced users. You may ignore this chapter if advanced configuration is not
required. Using an .ini file, users can define custom object types and rules for how
ReviewAdapter should handle these objects.

Number of objects
The file size of the resulting PDF file depends noticeably on the number of objects captured.
Ignoring less-meaningful objects (e.g. welds in SmartPlant 3D sessions) is one approach for
reducing the overall 3D PDF file size.
The following syntax is used to define a custom object type in the.ini file:
[ObjectDefinition]
ObjectTypeName=AttributeName Operator Value

Example:
[ObjectDefinition]
MyWeld=Component=Weld

[ObjectDefinition] is the section name in the .ini file. MyWeld is the object type name, which
can be freely defined. Component is an attribute name, which must exist in the design review
session. The “=” character after Component is the operator. The operator may be “=” and "<>"
for equality or “like” and "not like" when using wildcards. Weld is the attribute value.
The example defines that an object type MyWeld exists for the objects, whose attribute Component equals the value Weld. Users can build rules to ignore objects of type MyWeld using the
following syntax in the .ini file:
[IgnoreObject]
MyWeld=1

The .ini file name is ReviewAdapter.ini and is copied automatically from the installation template to the folder of the design review session loaded in ReviewAdapter. By default the following definitions exist in the .ini file to ignore welds of Smart 3D sessions:
[ObjectDefinition]
Weld=Component=Weld
Weld1=Commodity type Like *weld*
[IgnoreObject]
Weld=1
Weld1=1
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Log files
The software creates log files in the local TEMP directory (e.g. “C:\Temp\ReviewAdapter\”.
The user can also open these files by double-clicking on the CAXperts ReviewAdapter status
bar:

6

Technical support
Need more help? Contact CAXperts support by email, online, or phone:
mailto: support@caxperts.com
www.caxperts.com
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