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Introduction
UniversalPlantViewer Builder creates UniversalPlantViewer files and/or PDF documents
with 3D content, including attributes, project hierarchy and 2D Drawings (Isos) from Intergraph SmartPlant Review, Smart 3D, PDS and PDMS (via CAXperts Adapters).

1.1

General conventions
This document contains many visual cues to help you understand the meaning of certain
words or phrases. The use of different fonts for different types of information allows you
to scan the document for key concepts or commands. Symbols help abbreviate and identify commonly used words, phrases, or groups of related information

Typefaces
Italic

Indicates a system response, which is an explanation of what the software is doing. For example,
The text is placed in the viewing plane.

Bold

Indicates a command name, parameter name, or
dialog box title. Command paths are shown using
an arrow between command names. For example,
Choose File →Open to load a new file.

Normal
typewriter

Indicates an actual file or directory name. For example,
The ASCII report is stored in the layout.rpt file.

Bold typewriter

Indicates what you literally type in. For example,
Key in original.dat to load the ASCII file.

Symbols
This document uses the following symbols to identify special information:
Note – important supplemental information.
Map or path – shows you how to get to a specific command or form.
More information – indicates there is additional or related information.
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Installation
Requirements:
▪

Supported operating systems:
▪
▪
▪

▪
▪
▪

Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows 10

Microsoft .NET Framework 4.0
Microsoft Excel
Adobe Reader X or later

Administrator rights are required on each computer to install CAXperts UniversalPlantViewer Builder. “Run as” is not supported.

Uninstall
To uninstall the software, select Control panel from the start menu. Then on large or
small icon view, click Programs and features. If you are using category view, under Programs, click Uninstall a program.
Select the program you want to remove, and click Uninstall/Remove. Alternatively, rightclick the program and select Uninstall.

Setup command line (for administrators)
The following command line options are supported by the installer:
/S:<<optional ini file>>
Allow an install to be run in silent mode. As a result, no screens or dialogs will be shown.
This command line option also has an optional INI file that can be passed containing
session variable values. For example:
"C:\output\setup.exe" "/S:C:\setupvars.ini"

This will cause the session variables in the INI file to be used for the setup. The INI file
should be in the format:
[SetupValues]
%AppFolder%=C:\Program Files\MyProduct

/U:<<XML config file>>
This command line option must be used when calling the uninstall program from the
command line. This command also has an optional XML file that can be passed containing session variable values. For example:
"C:\Program Files\MyProduct\uninstall.exe" "/U:C:\Program Files\MyProduct\iru
nin.xml"
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2.1

Licence
CAXperts software supports two types of licences:

Site licence (local)
Domain based licences are restricted to machines within a 5 miles (8 kilometres) radius
at a specific geographic location (building) for which the licence key file was issued for.
There is no limitation regarding the number of users or machines.
CAXperts will need your Current domain name to issue a licence file (.lic).
The licence file has to be stored on a local or network location accessible by the machine
running the CAXperts product; a licence server is not required.
The loca on of the licence ﬁle should be deﬁned on every machine with the CAXperts product
installed, which can be done
•

Either by setting the environment variable
CAXPERTS_LICENSE_FILE=C:\Program Files (x86)\CAXperts\Licensing\

•

Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License
Manager\CAXPERTS_LICENSE_FILE=C:\Program Files
(x86)\CAXperts\Licensing\

Multiple licence key file locations should be separated by semicolons (“;”).
Note: If the licence key file location is not defined, “C:\Program Files (x86)\CAXperts\Licensing\” is used
Note: The licence key file may be renamed (including the extension). The CAXperts
product will check the content of all files in the licence folder(s) for valid keys.
Note: Changes to the key path (in the environment variable or registry key) are read
during the next start of the CAXperts product.

Floating (server) licence
Floating licences require a FlexNET server (lmadmin or lmgrd) accessible by the machine
running the CAXperts product. The licence key file is typically located on the FlexNET
server machine. The licence key file defines the maximum number of seats which can
be used at the same time.
Note: Every running instance of the CAXperts software product will require one
seat, no matter if the application is running multiple times on the same or different
machine(s).
New instances can only be started as long as seats are available and the FlexNET server
is accessible.
The location of the licence server must be defined on every machine with the CAXperts
product installed, which can be done
•

Either by setting the environment variable
CAXPERTS_LICENSE_FILE=@YourServerName
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•

Or by setting the registry key
HKEY_CURRENT_USER\Software\FLEXlm License
Manager\CAXPERTS_LICENSE_FILE=@YourServerName

Every computer name must be preceded by the @ symbol. Multiple licence server locations should be separated by semicolons (“;”).
YourServerName is the Windows computer name of the machine running lmadmin

(FlexNET server). If lmadmin is running on a non-default port, the port number should be
defined like this: port@ YourServerName.
Note: Changes to the server path (in the environment variable or registry key) are
read during the next start of the CAXperts product.
Borrowed licences
Licence seats can be borrowed for a period of time from the server and saved to the
local machine. Once the seat has been borrowed the CAXperts application can be used
without any connection to the FlexNET server.

To borrow a licence seat press the Borrow seat button, define the loan period (up to 7
days) and press OK. When the borrowed seat expires it gets automatically returned back
to the FlexNET server.

The seat can be returned earlier by pressing the Return borrowed seat button.
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Note: Without a valid licence file the software will run in demo mode.
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Overview
Based on model graphics and attributes captured by ReviewAdapter or PDMS ReportAdapter (*.upvc files) UniversalPlantViewer Builder creates:
-

UniversalPlantViewer sessions that can be viewed on Windows, Android and iOS
systems.
3D PDF files that can be viewed in Adobe Reader

Both output files formats and how to use them is described in additional manuals.
Note: Before using UniversalPlantViewer Builder, a UPVC file has to be created.
Please use ReviewAdapter (or PDMS ReportAdapter) to create a UPVC file.
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Using UniversalPlantViewer Builder
After the graphics have been captured by ReviewAdapter, open the *.upvc file in UniversalPlantViewer Builder. The session tasks/disciplines and attributes will be shown in a
tree view.

Package definition file: load a package definition file created by UPV and select single
packages. For each selected package a separate model will be generated.
Press the Generate output button to select the type of output session (UniversalPlantViewer or 3D PDF) and configure other parameters:
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Output type:
-

UniversalPlantViewer: creates a folder with 3D content, attributes and tree hierarchy,
which can be viewed in UniversalPlantViewer.
3D PDF: creates PDF file with 3D content, attributes and tree hierarchy, which can be
viewed in Adobe Acrobat Reader.

Settings:
-

-

Output folder: specifies the target directory
Excel colour file (optional): if defined the colours of the output 3D graphics can be
changed as defined in the Excel configuration file. An example can be found in Application Folder\Templates\DefaultConfig.xlsx
Expiration date (optional): if defined the created PDF file will no longer be available
for reviewing after the expiration date is reached.

UniversalPlantViewer settings (optional):
-

Colour files directory: include standard colour files that can be used by UniversalPlantViewer:

11

CAXperts UniversalPlantViewer Builder – Manual

-

-

-

Link mapping file: attach links to external documents

Drawing database: include content of an ISO drawing database
Attribute mapping file: for P&ID files generated with PID ReportAdapter, the link between P&ID and 3D can be defined here:

Allow download
Include plugin version
Use XYZ common views cube: new common views cube (-x, -y, -z, x, y, z)

3D PDF settings:
-
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Password (optional): if defined the created PDF file can be viewed only after entering
a valid password combination.
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4.1

Merge sessions

4.2

Settings
All settings are stored automatically in the configuration file of the user profile. The location of the configuration file can be changed in Tools →Settings.

Use File→Save settings to file to export the settings. To import the settings from file use
File →Load settings from file.
Note: Load settings from file doesn’t change the current location of the configuration file. Once the settings have been imported any further changes are stored in the
current configuration file displayed in menu Tools →Settings.

General
PDF settings
Header text: the text displayed in the bottom left corner of the PDF file as shown on the
screenshot below.
Logo: defines path to the logo file (*.jpg) which is displayed in the bottom right corner of
the PDF file as shown on the screenshot below.
Background colour: background colour of 3D content in the PDF file.
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Tree
On this tab the tree for UniversalPlantViewer and 3D PDF can be configured. To build a
tree hierarchy drag & drop attributes or select them from the list of available attributes
(on the left hand side) and add them to the list of used attributes (right hand side).

If one of the following special attributes is added to the list of used tree attributes UniversalPlantViewer Builder builds the tree automatically based on the content of all attributes ending on …path.
Show label in front of attribute: if enabled the attribute name is displayed in front of the
value in the tree: e.g. Area Name: Refining Area →Unit System: Distillation →… This functionality is available only for 3D PDF.
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Attributes
To make attributes visible in the UniversalPlantViewer or 3D PDF file drag & drop them
or select them from the list of available attributes (on the left hand side) and add them
to the list of used attributes (right hand side).
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4.3

Command line mode
UniversalPlantViewer Builder can also be used in command line mode to create WebViewer or 3D PDF files automatically from a batch script. Use the following command to
show the command line arguments:
C:\>”C:\Program Files\CAXperts\UniversalPlantViewer Builder\UniversalPlantViewer Builder.exe” /?

Command line arguments:

Example:
"C:\Program Files\CAXperts\UniversalPlantViewer Builder\UniversalPlantViewer
Builder.exe" –input C:\39_VUE_Madison\MADISON.upvc –pdf C:\Madison.pdf –upv
C:\UniversalPlantViewer
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Advanced features

5.1

Advanced configuration for capturing graphics
This chapter is for advanced users. You may ignore this chapter if advanced configuration is not required. Using an .ini file, users can define custom object types and rules for
how UniversalPlantViewer Builder should handle these objects.

Number of objects
The file size of the resulting PDF file depends noticeably on the number of objects captured. Ignoring less-meaningful objects (e.g. welds in SmartPlant 3D sessions) is one
approach for reducing the overall 3D PDF file size.
The following syntax is used to define a custom object type in the.ini file:
[ObjectDefinition]
ObjectTypeName=AttributeName Operator Value

Example:
[ObjectDefinition]
MyWeld=Component=Weld

[ObjectDefinition] is the section name in the .ini file. MyWeld is the object type name,
which can be freely defined. Component is an attribute name, which must exist in the
design review session. The “=” character after Component is the operator. The operator
may be “=” and "<>" for equality or “like” and "not like" when using wildcards. Weld is the
attribute value.
The example defines that an object type MyWeld exists for the objects, whose attribute
Component equals the value Weld. Users can build rules to ignore objects of type
MyWeld using the following syntax in the .ini file:
[IgnoreObject]
MyWeld=1

The .ini file name is UniversalPlantViewer.ini and is copied automatically from the
installation template to the folder of the design review session loaded in UniversalPlantViewer. By default the following definitions exist in the .ini file to ignore welds of
Smart 3D sessions:
[ObjectDefinition]
Weld=Component=Weld
Weld1=Commodity type Like *weld*
[IgnoreObject]
Weld=1
Weld1=1

17

CAXperts UniversalPlantViewer Builder – Manual

6

Log files
The software creates log files in the local TEMP directory (e.g. “C:\Temp\UniversalPlantViewer Builder\”. The user can also open these files by double-clicking on the
CAXperts UniversalPlantViewer Builder status bar:
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Technical support
Need more help? Contact CAXperts support by email, online, or phone:
mailto:support@caxperts.com
http://www.caxperts.com/contact/
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