ReportAdapter for SmartPlant® Electrical

ReportAdapter for SmartPlant® Electrical is designed to export a SmartPlant Electrical database into a Microsoft Access file, containing one table per task.

Installation

Setup

Requirements:

  • Supported operating systems:

  • Microsoft Windows XP

  • Microsoft Windows Server 2003

  • Microsoft Windows Vista

  • Microsoft Windows 7 or later

  • Intergraph SmartPlant Electrical 2007 SP 1 or later

Administrator rights are required on each computer to install CAXperts ReportAdapter for SmartPlant® Electrical. “Run as” is not supported.

Uninstall

To uninstall the software, select Control panel from the start menu. Then on

  • Windows 7-10: in large or small icon view, click Programs and features. If you're using category view, under Programs, click Uninstall a program.

  • Windows Vista: in classic view, double-click Programs and features. In control panel home view, under Programs, click Uninstall a program.

  • Windows XP/2000: (Double) click the Add or remove programs icon.

Select the program you want to remove, and click Uninstall/Remove. Alternatively, right-click the program and select Uninstall.

Setup command line (for administrators)

The following command line options are supported by the installer:

/S:<<optional ini file>>

Allow an install to be run in silent mode. As a result, no screens or dialogs will be shown.

This command line option also has an optional INI file that can be passed containing session variable values. For example:

"C:\output\setup.exe" "/S:C:\setupvars.ini"

This will cause the session variables in the INI file to be used for the setup. The INI file should be in the format:

[SetupValues]

%AppFolder%=C:\Program Files\MyProduct

/U:<<XML config file>>

This command line option must be used when calling the uninstall program from the command line. This command also has an optional XML file that can be passed containing session variable values. For example:

"C:\Program Files\MyProduct\uninstall.exe" "/U:C:\Program Files\MyProduct\irunin.xml"

Licence

CAXperts software supports two types of licences:

Site licence (local)

Domain based licences are restricted to machines within a 5 miles (8 kilometres) radius at a specific geographic location (building) for which the licence key file was issued for. There is no limitation regarding the number of users or machines.

CAXperts will need your Current domain name to issue a licence file (.lic).

The licence file has to be stored on a local or network location accessible by the machine running the CAXperts product; a licence server is not required.

The location of the licence file should be defined on every machine with the CAXperts product installed, which can be done

  • Either by setting the environment variable
    CAXPERTS_LICENSE_FILE=C:\Program Files (x86)\CAXperts\Licensing\

  • Or by setting the registry key
    > HKEY_CURRENT_USER\Software\FLEXlm License > Manager\CAXPERTS_LICENSE_FILE=C:\Program Files > (x86)\CAXperts\Licensing\

Multiple licence key file locations should be separated by semicolons (“;”).

If the licence key file location is not defined, “C:\Program Files (x86)\CAXperts\Licensing\” is used

The licence key file may be renamed (including the extension). The CAXperts product will check the content of all files in the licence folder(s) for valid keys.

Changes to the key path (in the environment variable or registry key) are read during the next start of the CAXperts product.

Floating (server) licence

Floating licences require a FlexNET server (lmadmin or lmgrd) accessible by the machine running the CAXperts product. The licence key file is typically located on the FlexNET server machine. The licence key file defines the maximum number of seats which can be used at the same time.

Every running instance of the CAXperts software product will require one seat, no matter if the application is running multiple times on the same or different machine(s).

New instances can only be started as long as seats are available and the FlexNET server is accessible.

The location of the licence server must be defined on every machine with the CAXperts product installed, which can be done

  • Either by setting the environment variable
    CAXPERTS_LICENSE_FILE=@YourServerName

  • Or by setting the registry key
    HKEY_CURRENT_USER\Software\FLEXlm License Manager\CAXPERTS_LICENSE_FILE=@YourServerName

Every computer name must be preceded by the @ symbol. Multiple licence server locations should be separated by semicolons (“;”).

YourServerName is the Windows computer name of the machine running lmadmin (FlexNET server). If lmadmin is running on a non-default port, the port number should be defined like this: port@ YourServerName.

Changes to the server path (in the environment variable or registry key) are read during the next start of the CAXperts product.

Borrowed licences

Licence seats can be borrowed for a period of time from the server and saved to the local machine. Once the seat has been borrowed the CAXperts application can be used without any connection to the FlexNET server.

To borrow a licence seat press the Borrow seat button, define the loan period (up to 7 days) and press OK. When the borrowed seat expires it gets automatically returned back to the FlexNET server.

The seat can be returned earlier by pressing the Return borrowed seat button.

Without a valid licence file the software will run in demo mode.

ReportAdapter for SmartPlant® Electrical

The ReportAdapter for SmartPlant® Electrical is used to extract SmartPlant Electrical data out of an existing project. The extraction of all data can be done without any knowledge of SmartPlant Electrical specific report creation. Plant breakdown structure filters can be used for extraction.

ReportAdapter for SmartPlant® Electrical requires SmartPlant Electrical licence seat on a SmartPlant Licence Server.

Setting up ReportAdapter for SmartPlant® Electrical

Extracting Data

Start ReportAdapter for SmartPlant® Electrical and select your plant from the combo box:

The plant breakdown structure of the selected plant will be displayed in the Plant breakdown structure filter field. Check the parts of the plant breakdown structure that shall be included during extraction.

Browse with the () button to select a location or type in the path and filename to create a Microsoft Access database file in which the results will be shown.

All the settings are stored automatically in the configuration file which is found under Tools → Settings.

Start the process by clicking the Extract button.

If the specified Access database already exists. A message box will appear whether to overwrite the existing file or not. In case of overwriting it, a backup of the existing file (.bak) is created first. A possibly existing backup file will be overwritten with the new backup.

To modify or add new attributes to the resulting Access database see “Configure Attributes”.

Configure attributes

ReportAdapter for SmartPlant® Electrical does not contain a predefined set of attributes which are reported by default. After starting the program for the first time, customer has to define and configure by his own. No database specific or programming knowledge is required.

Attributes are configured by task (Wiring, Electrical, PowerDistribution, ...). From the left side (Available attributes) user can access the attributes from SmartPlant® Electrical. The right side (Used attributes) contains the already predefined attributes. Drag the desired attributes from the left side to the right side or check them and use the > button. Drag from right to left or use the < button to remove attributes from the Used attributes list. A maximum of 230 attributes per task can be selected. If this number is exceeded the task will get a red font colour.

The display name of every attribute and the name of the originating table are shown on tooltips.

Press OK to finish the configuration.

The changes will be applied on the next extraction.

Additional SQL statements

Create additional SQL statements

SQL statements to extend standard output tables with user defined attributes or to perform some other tasks (like creating additional tables, queries) can be defined using Tools → Additional SQL statements. They will be executed automatically after the extraction process has been completed.

The additional SQL statements can be typed in the Additional SQL statements to be processed after extraction field. They have to look like the following examples:

SQL1=ALTER TABLE Equipment ADD COLUMN [MyAttribute] VARCHAR(255)

SQL2=UPDATE [Equipment] SET [MyAttribute] = 'Test'

Tables that can be used in the queries are those that will be created during extraction. Additional tables (if needed) have to be copied before extraction to the Template.mdb database which can be found in the application folder.

Use query builder

The included query builder can assist to create the SQL statements. Create a new statement with the Add button and add one of the Available SQL query templates to it. Add query or double-click on a list item will add the query at the cursor position or replace the selected text.

The Available SQL query templates look like:

UPDATE [%TABLE1%] SET [%TABLE1%].[%COLUMN1%]=

When the template is used, the %TABLE1% and %COLUMN1% fields will be filled with the table name and column name selected in the %TABLE1% and %COLUMN1% fields.

The %TABLE1% and %COLUMN1% fields are filled from the Access database defined for extraction output, which also includes the tables from Template.mdb. This means, the fields are only filled after the extraction was performed once.

With the Show hidden tables field checked, all tables of the database can be selected to build the query. If it is not checked, only tables that will be displayed in UniversalReporter are available and tables created for internal use are hidden.

Create new SQL query template

User defined SQL query templates can be created. To add a new template, click the Add button and enter the template name.

Fill in the text of SQL statement and the Placeholders for Tables and columns to be used by query textboxes by using the %TABLE"1% and %COLUMN1% buttons.

User defined templates can be deleted or modified using the Remove or Edit buttons.

The SQL text boxes support syntax highlighting.

Settings

All program settings (selected tasks, attributes and plant breakdown structure filters) are stored automatically for each plant in the configuration file located by default in the user profile folder. The location of the configuration file can be changed by using menu Tools->Settings.

Load settings from file

To import settings into the plant configuration file use menu “File->Load settings from file”.

The location of the plant configuration file is not affected, only the content of the file will be overwritten.

Save settings to file

To export the settings from the plant configuration file use menu “File->Save settings to file”.

The location of the plant configuration file is not affected.

Content of result database

When extraction process has finished, resulting database in Microsoft Access is available in the specified location. The database contains the configured tasks and attributes. Some key attributes (e.g. SP_ID, SP_PLANTGROUPID) are extracted independent of being configured or not. These are needed for internal use.

Command line mode

The ReportAdapter for SmartPlant® Electrical can be used from the command line to automate the extraction out of SmartPlant Electrical data.

To get the ReportAdapter batch mode help, type in the installation path of ReportAdapter followed by “\El ReportAdapter.exe” /?, e.g.

C:\>“C:\Program Files\CAXperts\El ReportAdapter\El ReportAdapter.exe” /?

"El ReportAdapter.exe" [/config config_file.ini] [/output output_file.mdb]

::: {.Definition} /config config_file.ini ::: Path and filename of the configuration file which contains the settings for the extraction related to the plant to process. Configuration includes tasks, attributes and plant breakdown attribute filter.

/output output_file.mdb

Path and filename of the output database.