ReportAdapter for SmartPlant® Instrumentation

ReportAdapter for SmartPlant® Instrumentation is designed to export a SmartPlant Instrumentation database into a Microsoft Access file, containing one table per task.

Installation

Requirements:

  • Supported operating systems:

  • Microsoft Windows XP

  • Microsoft Windows Server 2003

  • Microsoft Windows Vista

  • Microsoft Windows 7 or later

  • Intergraph SmartPlant Instrumentation 2007 SP 5 or later

Administrator rights are required on each computer to install CAXperts ReportAdapter for SmartPlant® Instrumentation. “Run as” is not supported.

Uninstall

To uninstall the software, select Control panel from the start menu. Then on

  • Windows 7: in large or small icon view, click Programs and features. If you're using category view, under Programs, click Uninstall a program.

  • Windows Vista: in classic view, double-click Programs and features. In control panel home view, under Programs, click Uninstall a program.

  • Windows XP/2000: (Double) click the Add or remove programs icon.

Select the program you want to remove, and click Uninstall/Remove. Alternatively, right-click the program and select Uninstall.

Setup command line (for administrators)

The following command line options are supported by the installer:

/S:<<optional ini file>>

Allow an install to be run in silent mode. As a result, no screens or dialogs will be shown.

This command line option also has an optional INI file that can be passed containing session variable values. For example:

"C:\output\setup.exe" "/S:C:\setupvars.ini"

This will cause the session variables in the INI file to be used for the setup. The INI file should be in the format:

[SetupValues]

%AppFolder%=C:\Program Files\MyProduct

/U:<<XML config file>>

This command line option must be used when calling the uninstall program from the command line. This command also has an optional XML file that can be passed containing session variable values. For example:

"C:\Program Files\MyProduct\uninstall.exe" "/U:C:\Program Files\MyProduct\irunin.xml"

Licence

CAXperts software supports two types of licences:

Site licence (local)

Domain based licences are restricted to machines within a 5 miles (8 kilometres) radius at a specific geographic location (building) for which the licence key file was issued for. There is no limitation regarding the number of users or machines.

CAXperts will need your Current domain name to issue a licence file (.lic).

The licence file has to be stored on a local or network location accessible by the machine running the CAXperts product; a licence server is not required.

The location of the licence file should be defined on every machine with the CAXperts product installed, which can be done

  • Either by setting the environment variable
    CAXPERTS_LICENSE_FILE=C:\Program Files (x86)\CAXperts\Licensing\

  • Or by setting the registry key
    > HKEY_CURRENT_USER\Software\FLEXlm License > Manager\CAXPERTS_LICENSE_FILE=C:\Program Files > (x86)\CAXperts\Licensing\

Multiple licence key file locations should be separated by semicolons (“;”).

If the licence key file location is not defined, “C:\Program Files (x86)\CAXperts\Licensing\” is used

The licence key file may be renamed (including the extension). The CAXperts product will check the content of all files in the licence folder(s) for valid keys.

Changes to the key path (in the environment variable or registry key) are read during the next start of the CAXperts product.

Floating (server) licence

Floating licences require a FlexNET server (lmadmin or lmgrd) accessible by the machine running the CAXperts product. The licence key file is typically located on the FlexNET server machine. The licence key file defines the maximum number of seats which can be used at the same time.

Every running instance of the CAXperts software product will require one seat, no matter if the application is running multiple times on the same or different machine(s).

New instances can only be started as long as seats are available and the FlexNET server is accessible.

The location of the licence server must be defined on every machine with the CAXperts product installed, which can be done

  • Either by setting the environment variable
    CAXPERTS_LICENSE_FILE=@YourServerName

  • Or by setting the registry key
    HKEY_CURRENT_USER\Software\FLEXlm License Manager\CAXPERTS_LICENSE_FILE=@YourServerName

Every computer name must be preceded by the @ symbol. Multiple licence server locations should be separated by semicolons (“;”).

YourServerName is the Windows computer name of the machine running lmadmin (FlexNET server). If lmadmin is running on a non-default port, the port number should be defined like this: port@ YourServerName.

Changes to the server path (in the environment variable or registry key) are read during the next start of the CAXperts product.

Borrowed licences

Licence seats can be borrowed for a period of time from the server and saved to the local machine. Once the seat has been borrowed the CAXperts application can be used without any connection to the FlexNET server.

To borrow a licence seat press the Borrow seat button, define the loan period (up to 7 days) and press OK. When the borrowed seat expires it gets automatically returned back to the FlexNET server.

The seat can be returned earlier by pressing the Return borrowed seat button.

Without a valid licence file the software will run in demo mode.

ReportAdapter for SmartPlant® Instrumentation

The ReportAdapter for SmartPlant® Instrumentation is used to extract SmartPlant Instrumentation data out of an existing project. The extraction of all data can be done without any knowledge of SmartPlant Instrumentation specific report creation. Plant breakdown structure filters can be used for extraction.

ReportAdapter for SmartPlant® Instrumentation requires a SmartPlant Instrumentation licence seat on a SmartPlant Licence Server.

Setting up ReportAdapter for SmartPlant® Instrumentation

Extracting data

Start ReportAdapter for SmartPlant® Instrumentation and select your database (profile) and plant from the combo box:

The database selection is only available if the Intools.ini files allows the user to switch between databases when opening SPI.

If the Intools.ini file only points to one database then the first row remains empty and only the Domain/Plant can be selected.

ReportAdapter for SmartPlant® Instrumentation will always connect to the database that was last opened with SmartPlant® Instrumentation.

The plant breakdown structure of the selected plant will be displayed in the Plant breakdown structure filter field. Check the parts of the plant breakdown structure that shall be included during extraction.

Browse with the () button to select a location to create a Microsoft Access database file in which the results will be shown.

All the settings are stored automatically in the configuration file which is found under Tools → Settings.

Start the process by clicking the Extract button.

If the specified Access database already exists. A message box will appear whether to overwrite the existing file or not. In case of overwriting it, a backup of the existing file (.bak) is created first. A possibly existing backup file will be overwritten with the new backup.

Depending on the settings (see Add manual extract info) additional information can be added to extracted data. If the option Add manual extract info is set another window will come up, before extraction, where information like revision number or a description can be added. This information is stored in the output database and can be recalled in UniversalReporter (or ApplicationReporter).

The field Days valid can be used to define a period during which the extracted data are valid. After this period UniversalReporter (or ApplicationReporter) will display a warning whenever the database is opened.

Days valid has to be a positive number (or empty); all other fields are text fields with up to 255 characters.

To modify or add new attributes to the resulting Access database see Configure Attributes.

Configure attributes

ReportAdapter for SmartPlant® Instrumentation does not contain a predefined set of attributes which are reported by default. After starting the program for the first time, customer has to define and configure by his own. No database specific or programming knowledge is required.

Attributes are configured by task (Cabling, Document, InstrumentLoop etc.). From the left side (Available attributes) user can access the attributes from SmartPlant® Instrumentation. The right side (Used attributes) contains the already predefined attributes. Drag the desired attributes from the left side to the right side or check them and use the > button. Drag from right to left or use the < button to remove attributes from the Used attributes list. A maximum of 230 attributes per task can be selected. If this number is exceeded the task will get a red font colour.

Press OK to finish the configuration.

The changes will be applied on the next extraction.

Specialties when selecting attributes:

Custom fields: only custom fields which are defined in the Admin module will be listed in the Attribute configuration interface.

Custom tables: only custom tables which are defined in the Admin module will be listed in the Attribute configuration interface. The CustomTable values are decoded during the extraction.

Component Function UDFs are also available for extraction:

DrawingType:
The field Drawing_Type_Name was added to the list of attributes in the “Document” area to show the type of a document (SpecSheet, HookUp etc.)

In Universal Reporter it will display the document name and the drawing type:

Decreased attribute list: Attributes with the display name “Not for display” are not shown any more (they were visible in older releases of Ins ReportAdapter). One exception is the “CMPNT_SUFF” attribute (Instrument Suffix) which is visible in the list of attributes.

Option to hide ID fields: if the option is selected then the ID fields are hidden and not visible in the attribute selection interface

Below is an example for Instrument Loop with ID fields:

Additional SQL statements

Create additional SQL statements

SQL statements to extend standard output tables with user defined attributes or to perform some other tasks (like creating additional tables, queries) can be defined using Tools → Additional SQL statements. They will be executed automatically after the extraction process has been completed.

The additional SQL statements can be typed in the Additional SQL statements to be processed after extraction field. They have to look like the following examples:

SQL1=ALTER TABLE InstrumentLoop ADD COLUMN [MyAttribute] VARCHAR(255)

SQL2=UPDATE [InstrumentLoop] SET [MyAttribute] = 'Test'

Tables that can be used in the queries are those that will be created during extraction. Additional tables (if needed) have to be copied before extraction to the Template.mdb database which can be found in the application folder.

Use query builder

The included query builder can assist to create the SQL statements. Create a new statement with the Add button and add one of the Available SQL query templates to it. Add query or double-click on a list item will add the query at the cursor position or replace the selected text.

The Available SQL query templates look like:

UPDATE [%TABLE1%] SET [%TABLE1%].[%COLUMN1%]=

When the template is used, the %TABLE1% and %COLUMN1% fields will be filled with the table name and column name selected in the %TABLE1% and %COLUMN1% fields.

The %TABLE1% and %COLUMN1% fields are filled from the Access database defined for extraction output, which also includes the tables from Template.mdb. This means, the fields are only filled after the extraction was performed once.

With the Show hidden tables field checked, all tables of the database can be selected to build the query. If it is not checked, only tables that will be displayed in UniversalReporter are available and tables created for internal use are hidden.

Create new SQL query template

User defined SQL query templates can be created. To add a new template, click the Add button and enter the template name.

Fill in the text of SQL statement and the Placeholders for Tables and columns to be used by query textboxes by using the %TABLE"1% and %COLUMN1% buttons.

User defined templates can be deleted or modified using the Remove or Edit buttons.

The SQL text boxes support syntax highlighting.

Settings

All program settings (selected tasks, attributes and plant breakdown structure filters) are stored automatically for each plant in the configuration file located by default in the user profile folder. The location of the configuration file can be changed by using menu Tools → Settings.

Load settings from file

To import settings into the plant configuration file use menu File → Load settings from file.

The location of the plant configuration file is not affected, only the content of the file will be overwritten.

Save settings to file

To export the settings from the plant configuration file use menu File → Save settings to file.

The location of the plant configuration file is not affected.

Add manual extract info

Under Tools → Settings the user can configure whether he wants to enter additional information that will be stored together with the extracted data.

Only if Add manual extract info is checked, additional information can be added before extraction.

If Keep last values is checked, the Information window will be filled with the values last used for the selected plant.

Content of result database

When extraction process has finished, resulting database in Microsoft Access is available in the specified location. The database contains the configured tasks and attributes. Some key attributes (e.g. loop_ID, equipment_ID) are extracted independent of being configured or not. These are needed for internal use.

Command line mode

The ReportAdapter for SmartPlant® Instrumentation can be used from the command line to automate the extraction out of SmartPlant Instrumentation data.

To get the ReportAdapter batch mode help, type in the installation path of ReportAdapter followed by “\Inst ReportAdapter.exe” /?, e.g.

C:\>“C:\Program Files\CAXperts\Inst ReportAdapter\Inst ReportAdapter.exe” /?

::: {.Definition} > /config config_file.ini ::: Path and filename of the configuration file which contains the settings for the extraction related to the plant to process. Configuration includes tasks, attributes and plant breakdown attribute filter.

/output output_file.mdb

Path and filename of the output database

/domain domain_name

Name of the Domain

/plant plant_name

Plant Name

/database database_name

Name of the database (mandatory)

/area area_name

Name of the Area (from the hierarchy)

/unit unit_name

Name of the Unit (from the hierarchy)