Show only results for:









IntelliPID Module

IntelliPID is a module for UniversalPlantViewer (UPV) to show P&ID contents, including attributes and project hierarchy. The content is created in two steps:

  • Step 1 – creating the P&ID input for UniversalPlantViewer (.upvp file).

    • By exporting data from Smart P&ID with CAXperts IntelliPID Adapter.

    • By converting PDF P&IDs with the CAXperts PDF2PID Adapter.

  • Step 2 – creating a session with UniversalPlantViewer Builder

    • This can include P&ID information only as well as

    • Full 3D models with advanced linking between P&ID and 3D.

User interface

The IntelliPID modules Interface is divided into the following Areas:

  • The central P&ID Viewport where the P&IDs are displayed.

  • The Breadcrumb Hierarchy (red) is used to navigate the P&IDs by > hierarchy.

  • The Left Menu bar (blue) attached to the left side of the screen.

  • The Right Panel (green) showing attributes of the selected object(s) > or files attached to the model

  • The Tab Bar (orange) at the bottom of the screen showing 3D, opened > P&IDs or documents.

Find more details about these areas and their integrated functions in the following chapters.

Left side menu

The Left Menu is the main menu for UniversalPlantViewer, gaining access to the central functions available from all views. If you need the full Viewport, the Left menu can be collapsed by the “H” button [].

Search in current IntelliPID

The Search in IntelliPID button opens a search field (image above) to search the currently displayed P&ID for the string entered. A count of the matches is shown right of the search string. All matches containing the requested string are considered (wildcards are not supported).

This search function searches the currently active P&ID only. For a global search, please use the Advanced search.

The arrows right of the match count are used to navigate between the matches. Arrow UP jumps to the previous match, arrow DOWN to the next match.

Zoom control

Zoom in/out by either clicking the buttons, using the mouse wheel, or pressing and holding the right mouse button and moving the mouse up/down. On a touch screen, pinch your fingers: pinching apart to zooming in, pinching together to zoom out.
Fit will center the screen on the selected elements and zoom in to fit into the Viewport. If no object is selected, the current P&ID will be zoomed to fit into the Viewport.
Pan will activate the panning function. Alternatively, press and hold the middle mouse button in the Viewport, the mouse wheel or if none of these apply, left and right mouse button simultaneously. On mobile devices, swipe the screen with two fingers for panning.

Colourise selected objects

You can change the display colour of selected objects by opening the Colour menu. This menu is separated in four basic sections as depicted below:

Colour options

Advanced colour selection – This opens a pop-up menu for detailed color selection, enabling you to pick from the full RGP spectrum of colors:

Once the colour is set up as required, confirm [] or cancel [] your selection. The selected object(s) will instantly be displayed in the chosen colour.

The colour picker allows you to pick a colour from a 3D object and store it in the “custom colours”. These can be selected afterwards from the colour palette like the default colours.
When the function is activated, first click on an object you want to draw the colour from and then pick a white custom colour square to assign the picked colour to it.
The clear style button reverts the assigned colour to the selected objects’ default colour as initially assigned in the building process.
The reset all colours button reverts all assigned colours for all objects to their default colour as initially assigned in the building process.

Default colours

The default colours section provides a basic set of default colours that can be applied to the currently selected objects. These colours are predefined.

Custom colours

The custom colours are defined by the user through the colour picker function described above. After their definition, they can be used for colouring like the default colours.

Opacity setting

The slider on the bottom changes opacity, where the leftmost position is fully transparent, and the rightmost position means the selected objects are fully opaque.

P&ID navigation

Go to P&ID – When an OPC (off-page connector) is selected, by clicking on this button the linked P&ID is being opened. The view zooms in on the according OPC on the linked P&ID.
Close all IntelliPID tabs – Closes all currently open IntelliPID P&IDs and clears them from the tab bar. All unsaved Sketches, markups and colouring will be discarded.

Tools menu

The Tools menu contains some useful tools for visualisation of IntelliPID content. When clicked, the menu opens to the right showing the contained tools:
Automatic labelling – This function places labels on the currently displayed P&ID automatically, according to the settings for automatic labelling if the objects have one of the attributes defined in the Settings panel.
Highlight linked objects – This tool helps you identify those objects that have been successfully linked to the 3D model. For these objects, an intelligent link between 3D and P&ID is in function.

Custom Attributes panel

The Custom Attributes button is only visible when custom attributes have been defines in a custom attributes definition file. Further information about these files, their creation and syntax can be found in the section Custom Attributes of the chapter Custom settings.
Custom attributes are user defined attributes. They can be changed, stored, and reloaded on runtime. In the attributes panel (see Attributes panel in the Right panel). Custom attributes are displayed in yellow.

The button opens a custom attributes panel in the Right Panel:

Custom Attribute tool bar

Export all changes – This saves all data that has been entered into custom attributes in a single .xlsx file with the respective information of the item they have been linked to.
Import all changes – This loads previously saved custom attribute values from an .xlsx file back into the custom attributes.
Send email – Changes to the custom attributes are internally logged for the session. By clicking on this button, a list of changes is generated and copied to the clipboard. A new mail is opened in your standard email client. The default recipient and subject are defined in the ‘Meta’ tab of IntelliPIDattributes.xlsx. Please see chapter Custom settings for more details.
Show only active – Custom attributes not used in the currently displayed P&ID will not be shown in the list of used values for this P&ID or the according legend.
Place legend – With this function, a legend with the according custom attribute colour keys is shown on the P&ID. This legend can be moved by dragging it to any location on the P&ID. See the description for custom attribute codelists and legend below.

Custom Attribute drop-down

This Drop-Down control lets you select from the custom attributes with codelist definitions. By default, ‘none’ is selected, and the P&ID colouring is set to standard. If a codelist custom attribute is selected, the objects in the P&ID will be coloured according to their custom attribute value and the legend will be displayed below.

Legend

The legend provides colour code information for the custom attribute selected from the drop-down described above. The unused values can be hidden with the function Show only active described above. The displayed (unhidden) colours and according values will be shown in the placed legend as described above accordingly.

Settings

Opens the settings panel for IntelliPID. You can set the main settings for P&IDs here:

Setting Description
Colour settings
Highlight Changes the highlight colour of selected elements.
Selected elements Changes the colour of selected elements.
Sheet background Changes the P&ID background colour.
Background elements Changes the colour of non-highlighted elements.
General settings
Text offset Changes the distance of the element-descriptions to the elements themselves.
Select attributes for automatic labelling Opens a selection popup for choosing attributes for automatic labelling. To select an attribute, drag and drop it to the right list. See picture on the next page.
Configure priority attributes Opens a selection popup for choosing priority attributes. To select an attribute, drag and drop it to the right list. See picture on the next page.
Preview attribute limit Defines the limit of the maximum number of attributes displayed in the tool tip that appears when hovering over any item. Attributes not available will be ignored.
Legend Font size
Font size Changes the font size used in the P&ID legend.
UI options
UI scale Changes the scale all User Interface (UI) elements are displayed by.
Reset UI scale Resets the UI scale to normal (factor 1).
Attribute font size Changes the font size, the attributes are displayed in the attributes panel on the right.

Automatic labelling settings

Priority attributes settings

The priority attributes are always displayed first in the attributes panel. This does not affect custom attributes; they are always displayed directly after the attribute they are attached to by definition - see the section Custom Attributes in the chapter Custom settings . In case the item the mouse is hovering over lacks one of the priority attributes selected, the next available attribute will be displayed instead with accordingly raised priority.

File menu

Extends the file menu bar to the right. The file menu contains the following functions:
Load display style – Opens a pop-up menu for display style selection. Your model is loaded with a default colour file, but additionally, you can load colouring settings depending on attribute conditions defined in colour files.

Depending on the settings in the upvcolorindex.txt, a list of custom defined display styles is displayed. Files not listed can be opened directly from the file system by clicking on Open local.

If a display style with colour groups is selected, you get to selectf which colour groups you want to activate.

You can create custom colour files using Excel by entering a colour and a condition. For more details about the settings and definitions, please see the section Colour Files in the Chapter Custom settings.

Place legend – Similar to the Custom Attributes, a legend according to the settings in your colour file can be placed on the P&ID. More details are to be found in the section Colour Files in the Chapter Custom settings.
Create report – This opens the report creation dialogue. Predefined custom and ad-hoc reports can be generated here. For more details, see the Chapter Reporting.
Export to PDF – Opens a file save dialogue for saving IntelliPID P&IDs to the PDF format. Several options are available for the PDF Export (see image on next page):
  • As shown – The P&ID will be exported as displayed, including > selection highlighting
  • As modified – The P&ID will be exported as displayed, selection > highlighting is ignored

  • Original – The P&ID will be exported in its original state, all > colouring being ignored

Additionally, a P&ID name filter can be applied to the list of available P&IDs. You get to select from this list using four selection options:

  • Manual selection – Select P&IDs by clicking, multiple selection > with the CTRL key pressed

  • Select current – Selects only the currently displayed P&ID

  • Select open – Selects all P&IDs currently open (visible in the > tab bar on the bottom)

  • Select all – Selects all P&IDs in the project

Load link file – Opens a file system dialogue to load a link file (.xlsx). For more details about the formatting and definition of links, see Link mapping files in the Chapter Custom settings.
Open manual – Opens this manual directly within UniversalPlantViewer.

Reporting

UniversalPlantViewer includes a powerful, yet easy-to-use reporting engine. The report creation dialogue is opened by the according button in the File menu in the Left menu.

Report creation dialogue

The report creation dialogue shows a list of predefined reports. These are defined in the Excel file IntelliPidReportDefition.xlsx. For more details about the definition of predefined reports, see section Report definitions in the Chapter Custom settings .

By selecting a report definition, the report result page is opened, and additional filters can be applied (more details below). Next to each report definition, there are two buttons:

Report Settings – This opens the Report Editor and allows you to conduct changes to the predefined report definition. For more details, see section Report editor below.
Save Report – This directly opens the file save dialogue. You can choose to save the report result directly to an .xlsx or .csv file for further usage outside UPV.

If none of the available report definitions apply, with the button “New” the Report Editor is opened.

Report editor

The report editor helps you generate reports easily:

  • Select if you want to include sketch data and attributes assigned to > sketch items (blue)

  • Choose the scope you want to report on. ‘All elements’ includes all > elements existing in the model.

  • Select the attributes you wish to report on by drag & drop to the > right.

The Reset button clears the Selected attributes table. All other settings remain untouched.

With the OK button the report is generated and the Report Results view is displayed.

Report Results

The Report Results are displayed in the Report Results screen. The screen is divided into the Report Menu at the left border of the screen and the Results by attributes. Multiple results can be selected by holding down the CTRL-key while clicking on the lines:

Report Menu

The report menu contains a series of functions that support you with narrowing down the results, locating the items on the P&ID or exporting the results:

Reload Report – Updates/refreshes the report if e.g. custom attributes have been changed.
View in model – Highlights the selected items in the according P&IDs. If the P&IDs are not open yet, they will be automatically opened and shown in the tab bar.
Select underlying objects – This function currently delivers the same results as View in model.
Copy current report definition – This function copies the current report definition to the clipboard to be saved into the Report Definition file. For more details, see section Report Definitions in the chapter Custom Settings Files.
Customize Report Settings – This opens the Report Editor and allows you to conduct changes to the current report definition. For more details, see section Report editor above.
Save Report – This directly opens the file save dialogue. You can choose to save the report result directly to an .xlsx or .csv file for further usage outside UPV.
Toogle quick filter – Toggles the quick filter functionality to narrow down report results. When activated, another line is shown underneath the attribute names (Wildcards applicable):

The line consists of a filter string field and two additional buttons:
Hide/show exclusive clauses – Enables to set additional filters for exclusively showing or hiding exactly defines values and shows the current number of values set.
Clear filter – clears and resets all filters
Filter combine mode – If several filters are set, by default, the filters are combined with an OR operator, requiring only one of the filter settings to be true. By switching to the AND operator, all filter conditions must be fulfilled for the item to be listed.

Right-click filter

To narrow down results even further, you can also right-click (or long-tap) an attribute value in the result list. A pop-up is displayed for showing or hiding the selected values exclusively:

All lines with according values will be either shown or hidden in the results list.

Custom attribute editing

If multiple lines are selected and a custom attribute with codelist is included in the report, they can be changed in bulk for all selected items:

For even more detailed reporting and advanced reporting features, please use the CAXperts UniversalReporter.

Right Side Menu

The Right Panel is a multi-purpose panel and varies in its function, depending on the context. The header section of the panel contains the following main views:

It provides access to the following views and features described in the following chapters:

  • Advanced search

  • Attributes panel

  • Files panel

If the Right panel obstructs the viewport (e.g. on mobile devices), it can be collapsed by clicking on the Hide menu button [] and reopened again with the Show menu button []

Besides the Search in current IntelliPID feature, UniversalPlantViewer has an advanced search function that is especially adapted for working with 3D and 2D drawings.

The results are displayed by the according attributes the string was found in. The number behind the attributes shows the number of matched groups in this attribute (grey) as well as the number of affected P&IDs (light blue). When an attribute is expanded, the matched groups are shown as a list, with the according P&ID name in light blue.

There are two different of results the search function delivers:

  • Hard results that exactly match the entered criteria. Displayed in light grey.

  • Soft results. Characters after the search string or those that are commonly added or dropped when converting data to another format are not considered during the search. (e.g. “slab 1 0002” and “slab-1-0002” both deliver results). Displayed in dark grey.

Make sure there is enough room for the display of your search results by dragging the bar under the search box downward. Otherwise maybe only Please select from search results will be visible.

Wildcards

You can add wildcards to the start or end of your search term:

  • ? stands for any single character or number

  • * stands for any number of characters or numbers (a* matches a, abc, a-12, …)

  • With >, <, =, => and =< you can search for attributes that start with a number. All numbers after text strings will be ignored.

Search result navigation

There are two ways to navigate the search results:

Go to previous/next group: Selects the previous/next group found. A group consists of coherent elements per P&ID. The numbers show the position within the found groups as well as the total number of matches. When navigating, the viewport selects the group and focuses on it.
Go to previous/next object: Navigates between all individual objects found in the selected group, e.g. pipeline, valves, etc.

Attributes panel

The attributes panel is displayed by default on start-up. It contains all attribute information for the selected item(s) provided during the building process (authoring system / UniversalPlantViewer SDK).

By double-clicking an attribute value, this value is copied to the clipboard for further usage.

In the upper part of the attributes panel, links attached to the selected object are displayed. You can attach links to websites, local and cloud-based documents, images and external systems, depending on their API.

Due to security reasons, links to executable programs and scripts are not possible.

Documents are opened with the standard application defined for the according file type in Windows.

If a linkage between 3D and P&ID has been established, a link to the linked objects in 3D is shown. By clicking on this link, UniversalPlantViewer selects the according objects in 3D and focuses on them.

A linked 3D object will also have a link with the P&IDs name in its attributes, enabling you to quickly switch between P&ID and 3D view for linked objects.

Custom Attributes

This section is about the display and editing of custom attributes. For information about the creation and syntax for setting up custom attributes, please check the section Custom Attributes of the chapter Custom settings.

Custom attributes in the Attributes panel can be easily recognized by their colour. In the standard view they are displayed in yellow and – as opposed to regular attributes – can be edited. Depending on the type of custom attribute, the editing varies.

While Freetext custom attributes are edited by typing in a custom value (like UPV/Comment attribute on the previous page), codelist attributes provide a drop-down with the options for selection.

Besides the selected value, codelist based custom attributes also show the colour assigned to the according custom attribute codelist colour scheme.

For loading, saving, or mailing changes to the custom attributes, please se the section Custom Attributes panel of the chapter Left menu.

When a custom attribute is selected in the Custom Attributes panel, the objects are not only coloured accordingly, the custom attribute in the Attributes panel is coloured red instead of yellow.

This can also be achieved by doble-clicking a custom attribute. While the colouring via the Custom Attributes panel affects all objects, by double-clicking the custom attribute the objects are only coloured according to the codelist colour scheme when clicked on in the viewport.

Files panel

The Files panel is a central space for UniversalPlantViewer files attached to the model. All Sketches, Markups, Comments, Views, etc. are displayed in a tree structure that makes it easy to navigate through all attached files.

Even though all nodes of the tree are always visible, there are some differences in file creation between 3D and IntelliPID. In this chapter, the specific IntelliPID functions are described along with some general features of the Files tree. The three sections of the panel are:

  • Tool bar – Tree editing and file operation features

  • Model root – The model root is always present and is the anchor for the tree structure.

  • Files tree – contains a hierarchical structure of the files attached to the model.

Files tool bar

File creation

The file creation button is context sensitive. Depending on the selected object at the time the arrow next to the Add button is clicked, different options are available. The files created are located underneath the selected file in the hierarchy:
Model root is selected
Folder is selected
PIDSketch is selected

Remove – Deletes the currently selected node (object) from the tree. In case of a folder, all files located in the folder will be deleted accordingly after a confirmation prompt.

Undo – Undoes the last change to the tree.
Redo – Redoes the last undone change to the tree.
Save – Triggers the save options as shown in the image below. Tree elements can be selected individually for saving. Deactivating a folder object leads to the deactivation of all objects located inside the folder hierarchy. After confirmation, a file save dialogue will be shown to pick a file name and location. The designated file type is .upvf.

Confirm the elements to be saved with [] or cancel the save process by clicking [].

Open – Opens a file open dialogue to select an .upvf file to be loaded. The loaded file is appended to the Files tree hierarchy automatically. For replace, remove existing hierarchy first.

File and object types

In IntelliPID, there are several file types available in the Files tree:

Folder – Adds a Folder object to the Model root. Subfolders are currently not supported. In folders, all other types of files can be stored in and thereby grouped. For multiple files to one P&ID, for example, you can create a folder that contains all relevant files for that P&ID.
P&ID markup – The markup file enables you to do markups on your P&IDs, including graphical objects. For detailed information, see the following Chapter P&ID markup.
P&ID sketch – The sketch file enables you to add sketches to your P&ID, including you custom P&ID symbols. For detailed information, see the Chapter P&ID sketch.
Comment – The commenting object contains one comment per node. Comments can be attached to any P&ID element, original or sketch. Commenting objects are always dependencies of a P&ID Sketch object. For more details, see the Chapter P&ID comment.

Double-clicking the Icon of an object opens that object directly. This also works when you are working in 3D. The according P&ID opens automatically and the viewport switches to the IntelliPID view.

Context buttons

All objects have context buttons to the right of the file/object node. Depending on the file/object type, different functions are available. They are visible when hovering with the mouse over the according node or when the object is clicked on.

Context controls

Edit – This button opens the according file in edit mode. An editor panel is shown in the right panel depending on the file type selected.
Show/Hide – This checkbox shows or hides the according file/object in the viewport.
Show/Hide Comment line – (Comments only) This button shows or hides the comment line leading from the comment to the object it is attached to.

P&ID markup

The Markup function in IntelliPID is a tool that enables you to create graphical and textual mark-ups to your P&ID (see section Files tool bar in the chapter Files panel). The P&ID becomes a virtual whiteboard the markup function draws upon without changing the underlying graphics. After assigning a name, an editor panel is opened at the bottom of the Right Panel:

Tool bar

Close markup - Closes the Markup and ends the editing mode.
Show initial screenshot – Shows a screenshot of the P&ID before Markup was applied.
Show last saved screenshot – Shows a screenshot of the P&ID in the state when editing was started. This includes Markups made previously.
Undo – Undoes the last action taken in Markup.
Redo – Redoes the last undone action.

Drawing tools

Draw free line – Creates a freehand line following mouse or finger movement in all directions.
Draw straight line – Creates a straight line in the direction of mouse or finger move.
Draw orthogonal line – Creates an orthogonal line bound to X and Y axis.
Draw rectangle – Draws a rectangle. Size is defined by mouse or finger movement.
Draw oval – Draws an oval. Size is defined by mouse or finger movement.
Draw text – Creates a text field at the position where the mouse is clicked. Font size and colour are defined by the pen definition. If an existing text is picked, this text can be edited.
Move – Enables you to move the currently selected element in any direction on the P&ID.
Erase – The erase tool erases graphically the positioned markups. It does not delete coherent objects but rather those part the tool is swiped over, resembling a sponge.
Pen templates – Sets the drawing pen to a fixed size and colour. The last template is transparent.

P&ID sketch

The P&ID Sketch function enables you to sketch into the existing P&IDs. Sketches are applied to a separate layer and do not alter the original document. P&ID Sketching offers pre-set objects as well as an access to a custom catalogue that can be set up by the user. For creation, see section Files tool bar in the chapter Files panel). After assigning a name, an editor panel is opened at the bottom of the Right Panel:
Tab Selector - The Tab selector lets you switch between the P&ID Sketch functions and the Catalogue.
PIDSketch name – shows the name of the currently open/edited P&ID Sketch and the according P&ID.

Tool bar

Close sketch - Closes the Markup and ends the editing mode.
Undo – Undoes the last action taken in Sketch.
Redo – Redoes the last undone action in Sketch.

Sketching tools

The Sketching Tools include the following presets and typicals for sketching into a P&ID.

Routing – Starts a pipeline routing process to sketch orthogonal lines. To finish routing, click or tap the button again or use the right mouse button.
Circle – Places a circular typical, e.g. for pumps. When placed, the line (original and sketch) it is placed upon will be interrupted to fit in the symbol.
Rectangle – Places a rectangular typical, e.g. for measurements, indicators, etc. When placed, the line (original and sketch) it is placed upon will be interrupted to fit in the symbol.
Valve – Places a general valve typical. When placed, the line (original and sketch) it is placed upon will be interrupted to fit in the symbol.

Commands

The Sketching Tools include the following presets and typicals for sketching into a P&ID.

Break line – Breaks the selected line and creates a separate segment between inline com­po­nents. For breaking a straight line into two segments, an object needs to be placed first. First click on the point you want the break to be placed, then click the Break line function. Depending on the positioning on the line the break will be applied to the closest end to clicked point:

Copy – Creates a copy of the selected object (original and sketch). The copy is attached to the mouse position and can be placed by clicking on the destination position.
Rotate – Rotates or mirrors the selected sketch item. Active rotation command is symbolised by the rotation symbol in the centre of the sketch item. The rotation commands are activated by clicking/tapping the respective symbol and dragging:
45° Rotation symbol – rotates the sketch item in 45° increments.
* *Rotation symbol – rotates the sketch item freely.**
* *Mirror symbol** – Flips the symbol axially in the dragged direction.
Change sketch colour – Opens a default colour selection pop-up (see section Colourise selected objects in the Chapter Left menu). The colour is applied to all sketch items in the current sketch.
Save colour to sketch – Manual colouring of original P&ID items can be stored in the sketch and will be loaded along with the sketch. The colouring of the original P&ID objects is not subject to change sketch colour and can be picked freely.

Sketch attributes

Sketch items possess only a few attributes by default. The default attribute NAME can be directly changed in the attributes panel. Just click into the value of the NAME attribute to change it:

If more attributes are needed, they can be added as necessary in the lower part of the attributes:

Enter the fields marked with “Enter text…” and type in you new attribute name on the left and the according new value on the right (green fields). To confirm the new attribute hit Enter or click on the Add Attribute button (marked red).

The new attribute will appear in the attribute list. If you wish to remove the attribute, klick on the red X symbol left to the new attribute value. The attribute will be deleted then.

Catalogue

The catalogue is a collection of custom sketching symbols for IntelliPID Sketching. It allows you to add custom P&ID sketching symbols to IntelliPID, enabling you to extend the sketching abilities and adapt sketching fully to your needs. When loading a model, UPV checks for a upvintellipidsketchitems.txt file located in the Data folder of your model. This file contains the linkage to all available items for the current model.

For more details about the sketch items list file and how to add your own custom symbols, see section Sketch item index file in the chapter Custom settings .

Catalogue items can be placed like items in the Objects tab.

P&ID comment

Create a comment for the currently selected P&ID object. The comment will attach to the centre of the object with a leader line. The leader line can be shown or hidden respectively – for further details, see section Context buttons in the chapter Files panel.

The name of the comment in the Files tree is identical to the comment content. Comments can be altered by either changing the name in the Files tree or by the Edit context button. While the first is helpful for short comments, the latter opens an Editor panel at the bottom of the Right panel:

This is suited for editing longer comments exceeding the size of the name field. After the editing of the comment in the panel is finished, close the panel by clicking on the button Apply text [].

Custom settings files

In UniversalPlantViewer, there is a series of files that can be used to customize the content and the options available in the software itself. This is a detailed listing of the different file types.

Autostart files

In UniversalPlantViewer, there are a couple of default and settings files that are automatically considered on UPV start-up. These files must be named exactly as shown in the list below for the autostart to work:

Location Name Function
.\Data\ Links.xlsx Linking file for external links and documents.
.\Data\ IntelliPidAttributes.xlsx definition of custom attributes to be used in IntelliPID
.\Data\ IntelliPidAttributeData.xlsx custom attribute values for IntelliPID to be loaded on UPV startup
.\Data\ IntelliPidReportDefinition.xlsx definition of reports and their filters for IntelliPID
.\Data\colorfiles\ upvcolorindex.txt listing of the default display styles to be listed in the Display Style Selection in the UPV Load display style menu.
.\Data\ upvintellipidsketchitemindex.txt Lists all catalogue items to be shown in IntelliPID Sketching.

There are three ways to add links to you UniversalPlantViewer model:

  • During the building process through a link mapping file

  • Automatically loading a link mapping file on start-up (Links.xlsx in the \Data\ Folder of the model)

  • Loading a link mapping file (see section File menu of the chapter Left side menu).

All three ways utilize the same type of definition in form of an Excel link mapping file:

Link - The Link can be either a weblink to a website or a web-based database with according link building (row 2), an absolute path (row 3) or a path relative to the model’s root directory (row 4), which is the directory the Data folder is located in.

Condition - The Condition can be any filter (incl. wildcards) relating to an Attribute in UniversalPlantViewer.

Name - The Name is the display name of the link. This is the text that will be shown in the Attributes panel in UPV.

Color - The colour setting can be either a hexadecimal RGB colour definition preceded by a # or one of the Excel default colours in clear name notation: black, white, red, green, blue, yellow, magenta, and cyan.

Custom Attributes

Custom attributes are user defined attributes that can be altered before each launch of UniversalPlantViewer. Their values can be changed at runtime (except calculation attributes). The Custom Attributes for IntelliPID are defined in the file IntelliPIDattributes.xlsx. This file can contain 4 worksheets (tabs):

  • Definition

  • Codelist

  • Filter

  • Meta

Worksheet “Definition”

In this worksheet, the custom attributes are defined:

Id – The Id of the custom attribute can be any number. The only condition is that an Id must be unique throughout the complete custom attributes list. This Id is later used for value assignment.

Name – The name the attribute is displayed by in UniversalPlantViewer

SourceAttribute – The attribute the custom attribute “attaches” itself to. E.g., SP_ID generates many entries since it attaches itself to any object with the attribute SP_ID. This may influence the performance of UPV.
It is highly recommended to use SourceAttribute as specific as possible.

Filter – Sets a filter to assign the custom attributes only to objects covered by the filter. A filter can be directly entered here (row 5), wildcards are valid. Instead, a predefined filter can be set (worksheet “Filter”).

Filters are applied sequentially. Consider using predefined filters instead. When the same filter is run several times in a definition, the according query will be executed several times. This can influence performance negatively.

DataType – The data type defines which properties an attribute will have. There are three basic types:

  • Calculation – Defines a value that will be calculated on UPV > launch. This is the only custom attribute that cannot be altered > during runtime. For IntelliPID, only the calculation HasLink is > available (DefaultValue “ThreeD” is mandatory) that gives back a > Boolean if the object exists in 3D.

  • Freetext – Defines a during runtime freely editable text > attribute. Accepts all value strings.

  • Codelist – Defines a codelist attribute. In UPV, these > attributes are displays as a combo box, enabling you to choose > from a predefined codelist of values – see worksheet “Codelist”.

DefaultValue – The value that will be assigned to the custom attribute automatically without any manual assignment being necessary. Depending on the DataType, there are different options available:

  • For Calculation – Only DefaultValue “ThreeD” is available.

  • For Freetext – can be left blank or contain any string.

  • For Codelist – The default value should be a value listed in the codelist definition.

Parameter1 – This parameter gives additional parameters, depending on the DataType of the attribute:

  • For Calculation – Only parameter “HasLink” is available.

  • For Freetext – not used

  • For Codelist – The name of the codelist to use, see worksheet “Codelist”

Id – The Id of the custom attribute can be any number. The only condition is that an Id must be unique throughout the complete custom attributes list. This Id is later used for value assignment.

Worksheet “Codelist”

In this worksheet, the codelists for the custom attributes are defined:

Name – The name of the codelist. This is the Name used in Parameter1 on worksheet “Definition”

Value – Defining all values available for the codelist in column A (Name)

Color – defines the colour the respective value will be shown in in UPV. This also affects the colour used in the legend. It can be either a hexadecimal RGB colour definition preceded by a # or one of the Excel default colours in clear name notation: black, white, red, green, blue, yellow, magenta, and cyan.

Worksheet “Filter”

In this worksheet, often used filters for the custom attribute definition can be set:

Filters entered in the worksheet “Definition” are always executed separately, even if the contents of the filter strings are identical. This can slow down the loading of the custom attributes on UPV launch.

Instead, you can use the worksheet “Filter” to define a referenced filter. Filters defined here are run only once, no matter how often they are invoked on the worksheet “Definition”. Whereas a direct filter runs every single time it is invoked, using the predefined filter reuses the result of the filter, thus increasing the performance of custom attributes loading.

Name – The unique name of the filter to be used as reference. This name can be freely assigned.

Filter – The actual filter string as described in the worksheet “Definition”. Wildcards are allowed.

Worksheet “Meta”

In this worksheet, the parameters for the mailing of custom attribute changes can be defined:

For IntelliPID, there are two keys available:

  • WorkcardMail_To – the recipient or list of recipients for the list of custom attribute changes.

  • WorkcardMail_Subject – the subject automatically added to the mail generated

Report definitions

To define a report that will be listed in the report selection list, the file IntelliPidReportDefinition.xlsx is used. There are two ways to create a new report definition:

Definition by copy

Create a new report and in the Report Results screen use the Copy current report definition function. This will copy the current report definition to the clipboard. Then paste the content of the clipboard to the next free row in the report definition file.

Manual definition

You can also create a report definition manually by editing the report definition file directly:

There are the following fields used to define a custom report. The fields highlighted are optional fields. They can stay empty without any impact on the functionality:

Name – The name of the codelist. This is the Name used in Parameter1 on worksheet “Definition”

Forbidden (optional) – define actions you wish to block for the report: C (customise), F (filter), or S (save).
You can also combine these restrictions with comma or semicolon. Example: C,F;S

Description (optional) – Additional description to explain the purpose of the report

Sort Column – defines the column by which the report will be sorted. If no prefix is added, the report will be sorted in asceding order. Optionally, you can add a prefix ascending: or descending: before the attribute.

Filter (optional) – All attributes, including custom attributes as well as wildcards can be used for filtering.

Scope (optional) – Define the scope of P&IDs. Options are All, All Open, CurrentDrawing, and Selected.

Attributes – Attributes to be included in the report. For every additional attribute, add an antry to the first free column to the right. The number of attributes to be reported on is not limited.

There are two additional special attributes for reporting: Color returns the current color of the object and “Count” gives you the number of objects contained in that object. For instance, a vessel with four nozzles will have a count of five.

Display styles

Colour list file

UniversalPlantViewer uses one central list file (upvcolorindex.txt) for the listing of available Display Styles. This file is located in the colorfiles folder of your model’s Data folder. It is automatically considered on launch. It contains the names of the colour files to be show by default in the Load display style selection in the File menu.

Colour Files

You can create custom colour files using Excel for the definition of colours, conditions and colour groups.

Color – defines colours to colourise the designated items. There are two ways to define a colour:

  • Use Excel colours in clear name notation: black, white, red, green, blue, yellow, magenta, and cyan.

  • Use HTML (hexadecimal) colour codes starting with # followed by 6 digits for the basic colours plus two optional digits for opacity: #RRGGBBOO. Please note that the hexadecimal values range from 00 (decimal 0) to FF (decimal 255).

For condition you can enter a filter for any attribute or custom attribute. Wildcards are supported.

Aspect is an option for 3D colouring and is not used for IntelliPID display styles.

GroupName is an optional value by which you can define separate colour groups in one file. This enables you to define several different conditions without the need to define separate colour files. Conditions belonging to the same colour group must have the exact same group name.

Sketch item index file

In order to use custom sketching items a Sketch Item index file has to be created and named upvintellipidsketchitemindex.txt. This file contains the paths to the according Sketch Item files you wish to be included in your model.

A catalogue item is a pair consisting of a .svg and a .jpg or .png file, where the .svg defines the graphics of the symbol itself while the .jpg/.png file delivers the symbol preview to be shown in the catalogue.

Adding object to the catalogue

You can add any .svg file and a corresponding .jpg / .png file (optional) to your catalogue. UPV will include it on model launch if the object is valid and properly listed with name and path in the file Sketch Item index file. You can use absolute paths, relative paths and include:

Absolute path - C:\temp\Pumps\pump2.svg

Relative Path – IntelliPidCatalogue\Valves\valve1.svg (relative to the location of your UPV model folder)

Include - #include D:\yourindex.txt - Include can be used to manage objects for the whole company in as many files as needed, rather than adding single objects to single models. In this example yourindex.txt stands for a separate Sketch Item index file.

Deep linking in IntelliPID

You can include deep links in all types of documents that support links, i.e. Word, websites, email … to open UniversalPlantViewer and transfer a combination of queries and commands.

Deep linking uses the URL handler upvapi://

Structure:

upvapi://<MODEL-URL>?<QUERY>&<COMMANDS>

Example:

upvapi://http://demo.universalplantviewer.com/demoPlant/6/0?Equipment%20ITEMTAG=D-240&CMD!Target=IntelliPid&CMD!OpenIntellipidDrawings&CMD!Select&CMD!Fit

This will look for the Equipment_ITEMTAG D-240, open the according drawing in IntelliPID, select the Item, highlight it and fit it to the screen.

There are no error messages for broken links, for example due to a typo. Please use %20 for including space characters.

Wildcards:

  • * = any character

  • _ = any single character

Condition operators

By default query conditions are combined with AND:

Equipment%20ITEMTAG=K-001&Nozzle Name=N5

OR is possible with the combine command:

Equipment%20ITEMTAG=K-001&Equipment%20ITEMTAG=D-100&CMD!Combine=OR